Le Chat Degraded
resolvedMEDIUMaffectedVibelasted 3min 47s
The incident has been resolved
resolved
Mar 6 13:12:04 (UTC)Requests to Le Chat are experiencing degraded service. We are currently investigating.
investigating
Mar 6 13:08:16 (UTC)The incident has been resolved
Requests to Le Chat are experiencing degraded service. We are currently investigating.