Le Chat Degraded
resolvedMEDIUMaffectedVibelasted 1min 24s
The incident has been resolved
resolved
May 17 05:26:13 (UTC)Requests to Le Chat are experiencing degraded service. We are currently investigating.
investigating
May 17 05:24:49 (UTC)The incident has been resolved
Requests to Le Chat are experiencing degraded service. We are currently investigating.